#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(by ).*(with)"
Local $sString = "from s32.hekko.net.com" & @CRLF & _
"by s32.hekko.net.com with LMTP id 0KRkJkxRu1qDS1AAbRxtZA" & @CRLF & _
"for <john@gmail.com>; Wed, 28 Mar 2018 10:24:44 +0200" & @CRLF & _
"Return-path: <johnsfather@onet.com>" & @CRLF & _
"Envelope-to: john@gmail.com" & @CRLF & _
"Delivery-date: Wed, 28 Mar 2018 10:24:44 +0200" & @CRLF & _
"" & @CRLF & _
"from smtpo114.poczta.onet.com ([213.180.149.147])" & @CRLF & _
"by s32.hekko.net.com with esmtps (TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256)" & @CRLF & _
"(Exim 4.90_1)" & @CRLF & _
"(envelope-from <johnsfather@onet.com>)" & @CRLF & _
"id 1f16Nv-00057D-Sj" & @CRLF & _
"for john@gmail.com; Wed, 28 Mar 2018 10:24:44 +0200" & @CRLF & _
"" & @CRLF & _
"from pmq4v.m5r2.onet (pmq4v.m5r2.onet [30.174.32.60])" & @CRLF & _
"by smtp.poczta.onet.com (Onet) with ESMTP id 40B2Bw16y9zqtBg4" & @CRLF & _
"for <john@gmail.com>; Wed, 28 Mar 2018 10:24:40 +0200 (CEST)" & @CRLF & _
"DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=onet.com; s=2011;" & @CRLF & _
"t=1522235480; bh=6YEU3a1jv48GQ33zI1zre2Sf05w2DqLyMQhJ7UmYfyM=;" & @CRLF & _
"h=From:To:Date:Subject:From;" & @CRLF & _
"b=svf7rTDJFp7gUMQFA6GShG07bYFIpsSaxPOvdXYad/2ln6x+BGE4z4OoIfqBgpGhE" & @CRLF & _
"2n43jucpTRvw7mdT33vor7NXnI6mMXjLZjJp6J4cOpxGLnuAnSEo0G/xLWirIgFmm4" & @CRLF & _
"TojYv7tx5z/PugqZc/c59WzApn14FEhmVSrC+1IE=" & @CRLF & _
"Content-Type: multipart/alternative; boundary="===============2073168411=="" & @CRLF & _
"MIME-Version: 1.0" & @CRLF & _
"" & @CRLF & _
"from [37.47.10.237] by pma4v.m5r2.onet via HTTP id" & @CRLF & _
"201803281024458192010001; Wed, 28 Mar 2018 10:24:40 +0200"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")