#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((UNION[^;]*);)"
Local $sString = "@b =" & @CRLF & _
" SELECT *" & @CRLF & _
" FROM @e;" & @CRLF & _
" UNION ALL" & @CRLF & _
" SELECT *" & @CRLF & _
" FROM @c_historical;" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"@r =" & @CRLF & _
" SELECT *" & @CRLF & _
" FROM @f;" & @CRLF & _
" UNION ALL" & @CRLF & _
" SELECT *" & @CRLF & _
" FROM @y_historical;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")