$re = '/(https:\/\/provider\.shsp\.swisscom\.com(?:(?!(:443|:80)(\/|\s))(?:(?::)(\d*)))*(?!:443|:80))+((?!\/stable(?=\/))(\/latest(?=\/))?)*/';
$str = '({"repository":"https://company.swisscom.local","remoteAppUrl":"https://provider.shsp.swisscom.com/","clientId":"eb922115-1e2d-4aa6-b79e-e0a02719d0ad","appWebUrl":"","subscriptionId":"ccf5cd8e-0a6b-4cca-8e3d-1576c4a23ae1","tenantId":"f486778e-3f8a-4d65-9864-3762839c950e","version":"1.61.0","isWorkspaceWebApplication":false,"workspaceRepository":"https://company.swisscom.local","providerInstance":"latest","adfsLogOutUrl":null},["https://provider.shsp.swisscom.com:443/latest/scripts/init/{lcid}/SCI.js?rev=279634fa70164cc4b9465e46146ead7f"],"https://cdn.shsp.azureedgnet.net/scripts/sharespace.js?v=1.61.0");';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);