$re = '/{((?:[^{}]*{[^{}]*}[^{}]*)*)}/m';
$str = '{{0}}
{{0,test}}
{test {0,test}}
{{0,test} test2}
{test {0,test} test2}
{test {0, test} test2 {1} test3 {2}}
{test {0, test} test2 {1} test3 {2} test4}
{test {0, test} test2 {1} test3 {2} test4} test5 {3}
{{0}}
{{0,test}}
{test {0,test}}
{{0,test} test2}
{test {0,test} test2}
test {test {0, test} test2 {1} test3 {2}}
test {test {0, test} test2 {1} test3 {2}} {3}
test {test {0, test} test2 {1} test3 {2}} asdf
{test {0, test} test2 {1} test3 {2}}
{test {0, test} test2 {1} test3 {2} test4}
{test {0, test} test2 {1} test3 {2} test4} test5 {3}
test {test {0, test} test2 {1} test3 {2}} -> test {0, test} test2 {1} test3 {2}
test {test {0, test} test2 {1} test3 {2}} {3} -> test {0, test} test2 {1} test3 {2}
test {test {0, test} test2 {1} test3 {2}} asdf -> test {0, test} test2 {1} test3 {2}
{test {0, test} test2 {1} test3 {2}} -> test {0, test} test2 {1} test3 {2}
{test {0, test} test2 {1} test3 {2} test4} -> test {0, test} test2 {1} test3 {2} test4
{test {0, test} test2 {1} test3 {2} test4} test5 {3} -> test {0, test} test2 {1} test3 {2} test4
{test {0, test} test2 {1} test3 {2} test4} test5 {3 -> test {0, test} test2 {1} test3 {2} test4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);