$re = '/^[a-z0-9.]+@[a-z0-9]+(\.[a-z]+)+$/i';
$str = 'stenioteste@usp.como.jjj';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);