package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)R"(?<rsldelim>[^(]*)\((.|\n)*?\)\k<rsldelim>"`)
var str = `LR"a(
)a"
)a"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}