const regex = /\[\[Image:([^][]*(?:\[\[[^][]*]][^][]*)*)]]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[Image:([^][]*(?:\\[\\[[^][]*]][^][]*)*)]]', 'gm')
const str = `[[Image:Justus Sustermans - Portrait of Galileo Galilei (Uffizi).jpg|left|thumb|upright|[[Galileo]] is often referred to as the Father of [[modern astronomy]], portrait by [[Justus Sustermans]]]]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}