using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[Image:((?>[^][]+|(\[\[(?:[^][]++|(?-1))*]]))*)]]";
string input = @"[[Image:Justus Sustermans - Portrait of Galileo Galilei (Uffizi).jpg|left|thumb|upright|[[Galileo]] is often referred to as the Father of [[modern astronomy]], portrait by [[Justus Sustermans]]]]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}