re = /\+([\d-]+)/m
str = '+1-541-754-3010 156 Alphand_St. <J Steeve>
133, Green, Rd. <E Kustur> NY-56423 ;+1-541-914-3010
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end