re = /(?<=!\[[^\]]*\]\()%([^%]+)%(?=\))/
str = 'this is an %test% asd example:   '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end