import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0|[1-9][0-9]*)$";
final String string = "0\n"
+ "1\n"
+ "-0\n"
+ "-1\n"
+ "+0\n"
+ "+1\n"
+ "01\n"
+ "-01\n"
+ "+01\n\n"
+ "2.3\n"
+ "-2.3\n"
+ "1.00\n"
+ "0.00\n"
+ "-0.00\n"
+ "00.00\n"
+ "-00.00\n"
+ "02.3\n"
+ ".0\n"
+ ".1\n"
+ "-.1\n"
+ "0.\n"
+ "1.\n"
+ "10.\n"
+ "2,3\n"
+ ",0\n\n"
+ "0e0\n"
+ "2e5\n"
+ "-e10\n"
+ "-e-10\n"
+ "2.3e5\n"
+ "-2.3e5\n"
+ "2.3e-5\n"
+ "2.3e03\n"
+ "2.3e0\n"
+ "0.01e4\n"
+ ".1e5\n"
+ "-.1e5\n"
+ "-.0e0\n"
+ "-0.0e10\n"
+ "2,3e5\n"
+ " \n"
+ ".\n"
+ "-\n"
+ "-.\n"
+ "b1\n"
+ "1b\n"
+ "2-3\n"
+ "3.4.5\n"
+ "4.,6\n"
+ "1,.\n"
+ "e\n"
+ "-e\n"
+ "-.e\n"
+ ".e4\n"
+ "1e2-2\n"
+ "e2.3\n"
+ "e2.3.4\n"
+ "-e10\n"
+ "1e.-\n"
+ "10e.\n"
+ "1\\n\n"
+ "1\\t\n"
+ "1 1\n"
+ "\\n\n"
+ "\\t\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}