import re
regex = re.compile(r"(?i)(data)\s+((\w+)(?=(\s*))(?:\4\w+)+)?\s*(\(((.|\n)*?)\);)?", flags=re.MULTILINE)
test_str = ("data foo (drop = DISCOUNT price RENAME = ( PROV_NM1= PROV_NM PROV_ST_NM1 = PROV_ST_NM) where = ( product = 'whizmo' and product < 10 )) bar( drop= DISCOUNT price rename= ( startDate = beginDate ) );\n\n"
"Data Data_asof&YrMon.;\n\n"
"data halfYear( drop= DISCOUNT price\n"
" rename= ( startDate = beginDate ) where=(product = 'abc' and price > 10) );\n\n"
"data apply_adj_v2 non_adjusted incorrect_acct;\n\n"
"data apply_adj_v2;\n\n"
"DATA INPDTL1(RENAME=(PROV_NM1=PROV_NM PROV_ST_NM1=PROV_ST_NM));\n\n"
"DATA REIMB_MTHD_CLM2;\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")