import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?: ^data | (?!^)\\G ) \\h+ ( \\w+ \\h* ( \\( (?: [^()]*+ | (?-1) )* \\) ) )";
final String string = "data foo (drop = DISCOUNT price RENAME = ( PROV_NM1= PROV_NM PROV_ST_NM1 = PROV_ST_NM) where = ( product = 'whizmo' and product < 10 )) bar( drop= DISCOUNT price rename= ( startDate = beginDate ) );\n\n"
+ "Data Data_asof&YrMon.;\n\n"
+ "data halfYear( drop= DISCOUNT price\n"
+ " rename= ( startDate = beginDate ) where=(product = 'abc' and price > 10) );\n\n"
+ "data apply_adj_v2 non_adjusted incorrect_acct;\n\n"
+ "data apply_adj_v2;\n\n"
+ "DATA INPDTL1(RENAME=(PROV_NM1=PROV_NM PROV_ST_NM1=PROV_ST_NM));\n\n"
+ "DATA REIMB_MTHD_CLM2;\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}