$re = '/^(\w+)=[\'"]?(.+?)[\'"]?$/m';
$str = 'LANG="en_US.UTF-8"
LANG=en_US.UTF-8
LANG=\'en_US.UTF-8\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);