package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^1|\D`)
var str = `+15555555555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}