using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/subtitles/.+\-english\-yify-\d+";
string input = @" http://www.yifysubtitles.com/subtitles/blockers2018720pwebripx264-ytsam-arabic-128849""><span class=""text-muted"">subtitle</span> Blockers.2018.720p.WEBRip.x264-[YTS.AM]</a></td><td class=""other-cell""></td><td class=""uploader-cell""><a href=""/user/SHINAWY"">SHINAWY</a></td><td class=""download-cell""><a href=""/subtitles/blockers-arabic-yify-128849"" class=""subtitle-download"" >download</a></td></tr><tr data-id=""128835""><td class=""rating-cell""><span class=""label"">0</span></td><td class=""flag-cell""><span class=""flag flag-cn""></span><span class=""sub-lang"">Chinese</span></td><td><a href=""/subtitles/blockers2018720pblurayx264-ytsmecht-chinese-128835""><span class=""text-muted"">subtitle</span> Blockers.2018.720p.BluRay.x264-[YTS.ME].cht </a></td><td class=""other-cell""></td><td class=""uploader-cell""><a href=""/user/osamawang"">osamawang</a></td><td class=""download-cell""><a href=""/subtitles/blockers-chinese-yify-128835"" class=""subtitle-download"" >download</a></td></tr><tr data-id=""128543"" class=""high-rating""><td class=""rating-cell""><span class=""label label-success"">6</span></td><td class=""flag-cell""><span class=""flag flag-gb""></span><span class=""sub-lang"">English</span></td><td><a href=""/subtitles/blockers2018web-dlx264-fgt-english-128543""><span class=""text-muted"">subtitle</span> Blockers.2018.WEB-DL.x264-FGT</a></td><td class=""other-cell""></td><td class=""uploader-cell""><a href=""/user/sub"">sub</a></td><td class=""download-cell""><a href=""/subtitles/blockers-english-yify-128543"" class=""subtitle-download"" >download</a></td></tr><tr data-id=""128633""><td class=""rating-cell""><span class=""label"">0</span></td><td class=""flag-cell""><span class=""flag flag-rs""></span><span class=""sub-lang"">Serbian</span></td><td><a href=""/subtitles/blockers2018720pblurayx264ytsag-serbian-128633""><span class=""text-muted"">subtitle</span> Blockers.2018.720p.BluRay.x264.[YTS.AG]</a></td><td class=""other-cell""></td><td class=""uploader-cell""><a href=""/user/TesneGace"">TesneGace</a></td><td class=""download-cell""><a href=""/subtitles/blockers-serbian-yify-128633"" class=""subtitle-download"" >download</a></td></tr><tr data-id=""128702""><td class=""rating-cell""><span class=""label label-success"">2</span></td><td class=""flag-cell""><span class=""flag flag-es""></span><span class=""sub-lang"">Spanish</span></td><td><a href=""/subtitles/blockers2018720pblurayx264ytsag-spanish-128702""><span class=""text-muted"">subtitle</span> Blockers.2018.720p.BluRay.x264.[YTS.AG]</a></td><td class=""other-cell""></td><td class=""uploader-cell""><a href=""/subtitles/blockers-english-yify-128543";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}