$re = '/\.1$/m';
$str = 'aa123
aa123.1
aa456
aa456.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);