re = /https?:\/\/[\/\\]*(www\.)?/m
str = 'https://
http://
https://\\/\\/
https:\\/\\/\\/\\/\\/\\
https://\\/\\/
The reason I include [\\/\\\\]* is because some links like: https://\\/\\/\\/\\/\\/www.google.com actually work.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end