re = /^(?:(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\.){3}(?:2[0-4][0-9]|25[0-5]|[0-1]?[0-9]?[0-9])$/m
str = '172.16.254.1
(?>!000|00|0)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end