re = /\|\{(\d+)}/m
str = '{1|{1078} {*|{1079}-}test{1|{4829}, test2 {4457}}} {*|{1078} {*|{1079}-}test3{1|{4829}, test4 {23232}}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end