re = /^(?!error|.*\.user)[\w.]+$/m
str = 'error.user
success
success.user
success.admin'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end