$re = '/(?:^|\s)(href=["\'](?!https?\b|\d))/m';
$str = '<link rel="stylesheet" th:href="@{css/fonts.css}" href="css/fonts.css" type="text/css" />
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);