import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\b([a-zA-Z]{0,2}\\d{6,12}[a-zA-Z]{0,2})\\b(?=(?:(?!\\bvisa\\b).)*?\\bpassport\\b)";
final String string = "T123125 is my Visa number and V123456, V123457 and V123458 are my passport numbers";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}