using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([abc])([+-]?)=([+-]?\w+)(?:([+-])(\w+))?";
string input = @"a=1, a=+1, a=-1, a=b, a=b+100, a=b-100, b+=10, b+=+10, b+=-10, b+=b, b+=b+100, b+=b-100, c-=101, c-=+101, c-=-101, c-=b, c-=b+101, c-=b-101";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}