using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((((End|end|Start|start)?\s)?#[1-9][0-9]* @([1-9][0-9]*(h|m?))+\s(.|\n|\r)+)|(Merge.+branch '.+'(.+into.+)?))";
string input = @"#2603 @1m sous modules
^((((End|end|Start|start)?\s)?#[1-9][0-9]* @([1-9][0-9]*(h|m?))+\s(.|\n|\r)+)|(Merge.+branch '.+'(.+into.+)?))";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}