re = /^([\w\s]+)(?:\((.+)\))?(!?): (.+)$/i
str = 'BREAKING CHANGE(scope)!: test'
# Print the match result
str.match(re) do |match|
puts match.to_s
end