$re = '/^-?(?!00)\d*\.?\d+$/m';
$str = '.5
0.500
3
0
0.0
30
500000
4000.22
.
00.5
0000.5
00
-4000
-0
-00
.
,
00.4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);