package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[ ]*(?:(?:\+)?1)?[ ]*(\()?(?:[2-9][0-9]{2})(?(1)\))[ ]*(?:-|\.)?[ ]*(?:[2-9][0-9]{2})[ ]*(?:-|\.)?[ ]*[0-9]{4}[ ]*$`)
var str = ` +1 (613)-995-0253
613-995-0253
1 613 995 0253
613.995.0253
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}