$re = '/(?<!0{10})ABCDEF/m';
$str = '0000000000ABCDEF
1234567890ABCDEF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);