$re = '/{VAR(?(?=:)[^}]*}|})/m';
$str = '{VAR}
{VAR10}
{VAR:10}
{VAR:something}
{VAR something}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);