#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(#(?:[A-z0-9]{3}){1,2})$"
Local $sString = "WHITE:" & @CRLF & _
"#FFFFFF" & @CRLF & _
"BLACK:" & @CRLF & _
"#000000" & @CRLF & _
"NOT THIS:" & @CRLF & _
"#12#111" & @CRLF & _
"Short hand grey:" & @CRLF & _
"#ccc" & @CRLF & _
"Invalid:" & @CRLF & _
"#efef" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")