# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:03|7[016])[- /]?\d{3} ?\d{3}\b"
test_str = ("03-123456\n"
"03123456\n"
"03 123 456 \n"
"03 123456\n"
"03/123456\n\n"
"Hi my name is marc and my phone number is 03-123456 and i would like 2 bottles of water 0.5L\n\n"
"Hi my name is marc 03-123456")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.