re = /^172\.(?:\b(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){2}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\b|null)$/
str = '172.12.12.12'
# Print the match result
str.match(re) do |match|
puts match.to_s
end