re = /^([A-PR-UWYZ0-9][A-HK-Y0-9][AEHMNPRTVXY0-9]?[ABEHMNPRVWXY0-9]?)\s{0,2}([0-9][ABD-HJLN-UW-Z]{2}|GIR 0AA)$/m
str = 'LS2 8NG
LS28NG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end