$re = '/^[0-9][0-9]{0,6}$/';
$str = '01566';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);