re = /\^(?P<name>.+)\^/m
str = '%B8954756016548963^LAST/FIRST INITIAL^180912345678912345678901234?;8954756016548963=180912345678912345678901234?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end