$re = '/\s+(-[A-Za-z]+|--[a-z-]+)/m';
$str = 'mycommand -t ARG -Targ --long --even-longer --long=option not-caught ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);