import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d+)\\b";
final String string = "Dim A As Integer = 1337\n"
+ "Dim B As Integer = (5 / 2)\n"
+ "Dim C$ = Base642String(A)";
final String subst = "CInt(\\1)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}