# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bcolou?r(?:[a-zA-Z’s]+)?(?=[ .,])"
test_str = ("Red is a color.\n"
"His collar is too tight or too colouuuurful.\n"
"These are bright colours.\n"
"These are bright colors.\n"
"Calorific is a scientific term.\n"
"“Your life is very colorful,” she said.\n"
"color (U.S. English, singular noun)\n"
"colour (British English, singular noun)\n"
"colors (U.S. English, plural noun)\n"
"colours (British English, plural noun)\n"
"color’s (U.S. English, possessive singular)\n"
"colour’s (British English, possessive singular)\n"
"colors’ (U.S. English, possessive plural)\n"
"colours’ (British English, possessive plural)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.