package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`return(\s|.)+end(\))?(\s+)?$`)
var str = `-- Hello, World!
local stuffBefore = 20
local function test()
print("Ayy")
end
return function()
print("Hello, World!")
return function()
print("Yes")
test()
end
end
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}