// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)RC[0-9]{6}.[0-9]{4}.[A-Za-z]{1}[0-9]{5}|MP[0-9]{6}.[0-9]{4}.[A-Za-z]{1}[0-9]{5}|CO[0-9]{6}.[0-9]{4}.[A-Za-z]{1}[0-9]{5}").unwrap();
let string = "Rechargement reussi. Montant de la transaction : 80 FCFA, ID transaction : RC220514.2328.A31840, Frais : 0 FCFA, Commission : 0 FCFA, Nouveau Solde : 0.28FCFA Other msisdn 658747305.
Paiement de FORFAIT INTERNET en succes par 658747305.
ID transaction: MP220512.2119.C83780, Montant: 250 FCFA.
Nouveau solde: 80.28 FCFA.
Retrait d'argent reussi par le 693734202 avec le Code : 226752. Informations detaillees : Montant: 2000 FCFA, Frais: 50 FCFA, No de transaction CO220428.2045.B63327, montant net debite 2050 FCFA, Nouveau solde: 387.1 FCFA.
CashOut success by 698039077 with the Code : 375533. Detailed information : Amount: 1500 FCFA, Fees: 45 FCFA, Transaction ID: CO211211.1932.C52092, Net amount debited 1545FCFA, New balance: 315.1 FCFA.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}