$re = '/^(\w+)(\d{1,2}\.\d{1,2})(?!\.)/';
$str = 'OpenSSH_for_Windows_7.7p1, LibreSSL 2.6.4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);