using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\D(\d{5})\D";
string input = @"\\SERVER\SMI Company\SMI Technical\SMI Drawings\UGI\11295- Feburary 2015 - XA-M Overhaul\asdf.dwg
""foo.bar 123 456789""
""foo.bar 456789 123""
\\SERVER\SMI Company\SMI Administrative\SMI Purchase Orders\SMI-2155.GHX
""foo.bar123 ""
no
""use.w.o.:this982too""
\\SERVER\SMI Company\SMI Administrative\SMI Purchase Orders\SMI-2355.GHX
23457f
w.o.: 12345
h4h5678
\\SERVER\SMI Company\SMI Technical\SMI Drawings\UGI\11295 - Feburary 2015 - XA-M Overhaul\asdf.dwg";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}