re = /^.+(\.[^.]+)$(?=\s*(?:(?!<tag>)[^.])+\1)|^(?!<tag>)[^.]+/m
str = '<tag>Adventures of Shuggy</tag>
!Shuggy.png
!Sound Bank.txt
test.txt
4.lwav
5.lwav
6.lwav
88.lwav
89.lwav
<tag>Adventures of Jack</tag>
90.lwav
91.lwav
92.lwav
93.lwav
!Sound Bank.xsb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end