using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""x-grid-cell-inner "" style=""text-align: left; ;"">([^<]*)<\/div>";
string input = @"<tbody><tr class=""x-grid-header-row""><th class=""x-grid-col-resizer-gridcolumn-1577"" style=""width: 1264px; height: 0px;""></th></tr><tr class=""x-grid-row x-grid-row-selected""><td class="" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first""><div class=""x-grid-cell-inner "" style=""text-align: left; ;"">Brigitte</div></td></tr><tr class=""x-grid-row x-grid-row-alt x-grid-row-selected""><td class="" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first""><div class=""x-grid-cell-inner "" style=""text-align: left; ;"">Ferhat</div></td></tr><tr class=""x-grid-row x-grid-row-selected""><td class="" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first""><div class=""x-grid-cell-inner "" style=""text-align: left; ;"">Hans</div></td></tr><tr class=""x-grid-row x-grid-row-alt x-grid-row-selected""><td class="" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first""><div class=""x-grid-cell-inner "" style=""text-align: left; ;"">Kevin</div></td></tr><tr class=""x-grid-row x-grid-row-selected""><td class="" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first""><div class=""x-grid-cell-inner "" style=""text-align: left; ;"">John</div></td></tr><tr class=""x-grid-row x-grid-row-alt x-grid-row-selected""><td class="" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first""><div class=""x-grid-cell-inner "" style=""text-align: left; ;"">Nathaniel</div></td></tr><tr class=""x-grid-row x-grid-row-selected""><td class="" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first""><div class=""x-grid-cell-inner "" style=""text-align: left; ;"">Flavia</div></td></tr><tr class=""x-grid-row x-grid-row-alt x-grid-row-selected""><td class="" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first""><div class=""x-grid-cell-inner "" style=""text-align: left; ;"">AJ</div></td></tr><tr class=""x-grid-row x-grid-row-selected""><td class="" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first""><div class=""x-grid-cell-inner "" style=""text-align: left; ;"">Marilyn</div></td></tr><tr class=""x-grid-row x-grid-row-alt x-grid-row-selected""><td class="" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first""><div class=""x-grid-cell-inner "" style=""text-align: left; ;"">Raymond</div></td></tr></tbody>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}