$re = '/^(?=.*?[\dA-Z!@#$%&*]).{7,20}$/m';
$str = 'Testertest
testing6
Tester@ok';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);