$re = '/(")""|"/m';
$str = '"StackOverflow"
"""StackOverflow"""
"""""StackOverflow""""" five quotes remain as one quote
""""""StackOverflow"""""" six quotes become two quotes';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;