import re
regex = re.compile(r"CA_[A-Z][0-9][A-Z]\h?[0-9][A-Z][0-9]|US_[0-9]{5}|GB_(?:(?:[A-Z][0-9]|[A-Z][0-9]{2}|[A-Z]{2}[0-9]|[A-Z]{2}[0-9]{2}|[A-Z][0-9][A-Z]|[A-Z]{2}[0-9][A-Z])\h?[0-9][A-Z]{2}|GIR\h?0AA)")
test_str = "CA_LSE2B9"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")