re = /^("+)((.*?)(?<!\\)(?:\\\\)*)\1$/m
str = '"""hello world"""""
""hello\\""world""
"hello\\"world"
"hello world\\\\"
"\\"hello world\\""
"hello world\\\\\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end