re = /\[([^\.]*)\.?([^\.\]]*)\]/
str = '[124dsqdab-cqqc.VALUE] and some other pair [VALUE]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end